EndCore Battles – Season 2 Upgrade Maintenance
Resolved
Feb 08 at 02:00pm UTC
We are upgrading EndCore Battles to bring you an all-new seasonal experience! This maintenance is part of our effort to introduce exciting new content, improvements, and enhanced gameplay across multiple game modes.
🔹 Lifesteal Season 1
We’ve refreshed gameplay mechanics and made balance adjustments to ensure every battle is thrilling and fair.
Expect:
- Smoother combat
- Optimized abilities
- Improved rewards for all players
🔹Practice Season 2
Step into brand-new arenas designed to enhance your PvP skills.
This season introduces:
- Updated mechanics for dueling
- New challenges to master
- Environments that make practice fun and competitive
🔹 EndWar Season 2
Prepare for epic battles with new challenges, abilities, and rewards.
EndWar has been reimagined to give players:
- More strategic options
- Intense combat scenarios
- Opportunities to climb the leaderboards
⚠️ Server & Dashboard Status
During this upgrade, some servers and the dashboard may be temporarily unavailable.
Our team is actively monitoring all systems to restore full functionality as quickly as possible.
We appreciate your patience as we roll out these updates.
Get ready to jump back into EndCore Battles Season 2 and experience the action like never before! ⚔️
Affected services