Back to overview
Downtime

⚠️ EndCore Battles Downtime

Feb 10 at 11:40am UTC
Affected services
endcore.rudracore.site

Resolved
Feb 11 at 01:37pm UTC

🟢 EndCore Battles — Server Status

All services are currently operational.

Uptime: Stable
Performance: Optimized (recent infrastructure upgrade)
Connections: Normal — players can join without issues
Gameplay: No known bugs affecting matches

If you experience any problems, open a support ticket in Discord and we’ll check it quickly.

endcore.rudracore.site

Created
Feb 10 at 11:40am UTC

Start Time: 15:00 IST
Status: Server temporarily offline

🧾 What happened

• Unexpected backend issue caused the network to stop responding
• Players were unable to join any modes (Lobby, Practice, Lifesteal, FFA, Duels)

🔧 What we did

• Restarted all nodes
• Checked plugins & database connections
• Applied stability fixes

📊 Current Situation

• Server is under recovery and monitoring
• Data and player progress are safe

We’ll update again once services are fully stable.